TinyUmbrella 5.10.00 – Neu mit iOS 5.1b1 Support

TinyUmbrella

Notcom hat TinyUmbrella 5.10.00 für Windows und Mac OSX veröffentlicht.

Mit TinyUmbrella 5.10.00 kann man neu die SHSH On File Zertifikate von iOS 5.1b1 sichern. Leider gibt es bis jetzt noch keine funktionierende Lösung um iOS Geräte auf iOS 5.x downzugraden die nicht mehr signiert werden von Apple.

Before you ask; Yes a solution for the 5.x firmware nonce is being investigated... None of us have a working solution yet though. Hang tight.
 
I have a couple trails and ideas I am trying out for 4.x baseband based restores to avoid 10xx errors. Until then save your signatures as you will never know when they may come in handy...
 
TinyPwn update: I've not had much time in the past month to work on this. Real life drama, work, etc have taken much of my time. I still intend on a release... eventually... :P Effectively it'll just have to be done when it's done...

Die neueste Version von TinyUmbrella für Windows und MacOSX könnt ihr euch von einem der folgenden Links herunterladen:

TinyUmbrella 7.11.00 - MacOSX (7.11.00)

TinyUmbrella 7.11.00 - Windows (7.11.00)

TinyUmbrella - Offizielle Seite

Eine passende Anleitung wie ihr die SHSH On File Zertifikate auslesen könnt, findet ihr hier:

Vergesst nicht fortlaufend die SHSH von euren Geräten zu speichern, damit ihr wieder auf eine ältere Firmware downgraden könnt auch wenn zur Zeit keine Möglichkeit besteht auf iOS 5.0 downzugraden. Man weiss nie ;)

viel Spass mit euren iDevices wünscht euch das hack2learn Team...

Copyright © www.hack2learn.org
Dieser Beitrag ist für den persönlichen, nicht-kommerziellen Gebrauch bestimmt. Die durch die Seitenbetreiber erstellten Inhalte und Werke auf diesen Seiten unterliegen dem deutschen Urheberrecht. Die Vervielfältigung, Bearbeitung, Verbreitung und jede Art der Verwertung ausserhalb der Grenzen des Urheberrechtes bedürfen der schriftlichen Zustimmung des jeweiligen Autors bzw. Erstellers.
(Digital Fingerprint: d3d3LmhhY2sybGVhcm4ub3Jn)

  • http://www.facebook.com/people/Frank-Rodigas/100001946028354 Frank Rodigas

    kann irgendwie garkeine shsh mehr sichern.
    von meinem 4er hab ich nur 4.3.5 alles andere geht nicht....
    warum? gejailbreakt ist es

    • http://www.hack2learn.org FatalSysError

      Hi Frank,
      schau dir bitte meinen Kommentar weiter unten an ;)

      Gruss
      FatalSysError

  • http://www.facebook.com/people/Michael-Petigk/1819710817 Michael Petigk

    hab iwie das gleiche problem... mein 4er sichert gar keine shsh mehr.... hab sogar schon den haken bei request SHSH bei cydia raus gemacht... stand glaub ich irgendwo das umbrella erst dann richtig sichert und auch abspeichert.... hab grad FW 4.2.1 drauf und er sichert garnix mehr... schade eigendlich... ich versuch es dann mal mit eine älteren version von tiny.... aber hoffe trotzdem ihr könnt mir/uns sagen wo der fehler liegt... oder wenigstens ob noch mehr leute von dem fehler betroffen sind.....

    • http://www.hack2learn.org FatalSysError

      Hi Frank & hi Michael,

      Also folgendes:
      Es gab mal eine Änderung in TinyUmbrella, da sich Apple gegen diese Art von Wiederherstellung mit TinyUmbrella, eine sogenannte Replay-Attacke, zu wehr setzte und dies seit den iOS 5.0 Beta's unterbindet. Mehr dazu findet ihr in folgendem Beitrag: http://www.hack2learn.org/2011/06/28/apple-unterbindet-mit-ios-5-0-den-downgrade-via-shsh-blobs

      Öffnet TinyUmbrella und klickt auf das Tab Advanced und schaut dann gleich mal nach, ob bei euch der Haken bei der Option Request SHSH From Cydia gesetzt ist:

      Ist die Option aktiviert, könnt ihr mit TinyUmbrella nur noch die bereits gesicherten SHSHs von dem Cydia Server herunterladen!

      Ist die Option deaktiviert, könnt ihr mit TinyUmbrella nur noch die SHSHs speichern, welche von Apple aktuell noch signiert werden, denn Apple stoppt die Signierung einer alten iOS Version, meist wenige Tage nach der Veröffentlichung einer neueren iOS Version!

      Um also an die aktuellsten SHSH Zertifikate zu kommen (zum Zeitpunkt meines Kommentares sind dies: iOS 5.0.1 (9A405) und 5.1b1 (9B5117b)) müsst ihr die Option Request SHSH From Cydia deaktivieren.

      Weiter solltet ihr euch versichern, dass TinyUmbrella nicht von einer Firewall blockiert wird. Schaut euch auch das Tab Log in TinyUmbrella genau an, nachdem ihr den Button Save SHSH gedrückt habt, denn darin steht ob's funktioniert hat oder eben nicht ;)

      Anderst sieht es bei den sogenannten SHSH Dumping Tools, wie iFaith von
      ih8sn0w oder der Stitching-Funktion von redsn0w aus: mit diesen Tools ist es möglich, die SHSH Zertifikate der aktuell installierten iOS Version auf einem Gerät auszulesen und so doch noch zu speichern, auch wenn Apple diese iOS Version bereits nicht mehr signiert.

      Nun hoffe ich, dass ihr eure SHSH Zertifikate ohne Probleme speichern könnt - falls doch nicht, meldet euch wieder.

      Gruss
      FatalSysError

      • http://www.facebook.com/people/Frank-Rodigas/100001946028354 Frank Rodigas

        wow nice! danke erstmal für den tip ;) es hatt funtioniert so wie du es beschrieben hast!
        1000000000 dank FatalSysError!!!!

        • http://www.facebook.com/people/Nick-Schulz/100002550161436 Nick Schulz

          Mir hat es auch sehr geholfen! Tausendfach dank!

  • http://www.facebook.com/people/Nick-Schulz/100002550161436 Nick Schulz

    Kann ich auch ältere shsh dateien von meinem Ipod sichern?
    Hab bedauerlicherweise vergessen die shsh datei von ios 5.0 und ios 4.xx zu sichern!
    :(

    • http://www.hack2learn.org FatalSysError

      Hi Nick,
      jaein > SHSH's welche man vergessen hat zu sichern, kann man nur noch mit Tools wie iFaith oder redsn0w sichern, sofern die gewünschte iOS Firmware noch auf dem Gerät installiert ist.

      Beispiel: du hast vergessen die SHSH von iOS 5.0 zu sichern, dann muss dein Gerät auch genau diese Firmware noch installiert haben, damit du mit iFaith oder redsn0w die SHSH Zertifikate aus deinem Gerät und der installierten Firmware auslesen und somit noch sichern kannst.

      Gruss
      FatalSysError